You need at least PHP 5.6 to install PrestaShop. Your current PHP version is 5.5.9-1ubuntu4.9